continua (next page) main index Nota: il resoconto dettagliato dell'installazione è in quest'altra pagina.


OpenSuse 10.3: il driver pata_sis è ancora poco maturo per le CF...

Primo approccio: avvio l'installazione della OpenSuse 10.3... Suprema tragedia: il suo driver pata_sis va in crash (perso un interrupt 14h, perciò consiglia di riavviare con irqpoll).

Riavvio l'installazione con irqpoll tra i parametri di boot del kernel, ma a quel punto l'accesso alla compactflash diventa di una lentezza esasperante.

Neppure i parametri libata.dma=4 ("compact flash DMA support") e ide=nodma danno risultato migliore. Occorre per forza quel lentissimo irqpoll.

Ero riuscito a formattare una partizione in ReiserFS da 1.8 Gb (ed un'altra di 65Mb di swap), ma vedo che al boot, ancor prima di attivare lo swap, il montaggio da finestra terminale richiede tempi mostruosi: quasi dodici minuti...
/ # time mount -t reiserfs /dev/sda1 /mnt

real    11m47.381s
user    0m0.004s
sys     0m0.088s

/ # time umount /mnt

real    0m2.690s
user    0m0.004s
sys     0m0.024s


Slackware 12

L'installazione della Slackware 12 è filata liscia fino al primo reboot. Il driver degli hard disk era ancora quello canonico di tutta la precedente tradizione del kernel Linux (i pata/sata sono stati rifatti da zero perché il driver IDE/ATA era diventato impossibile da manutenere a causa delle troppe tecnologie aggiuntesi in quindici anni di informatica). La velocità della Compactflash è più che ragionevole (pare quasi un hard disk vero), nonostante il BIOS riporti un inaudito "PIO mode 2" (dev'essere stato dai tempi dei primi PC/AT della fine degli anni ottanta, che non vedevo un PIO così lento).

Al reboot, la prima brutta sorpresa: il kernel non riesce a montare la partizione di root perché non ne riconosce il filesystem (avevo come al solito formattato in ReiserFS).

Riformattando con l'ext2 il problema si ripresenta uguale: "No filesystem could mount root. Tried:" senza però che indichi cosa ha provato: infatti immediatamente dopo segue il "Kernel Panic unable to mount root fs on unknown-block(3,1)" (da notare che "3,1" sono proprio i major/minor di /dev/hda1).

Morale della favola: durante l'installazione avevo deselezionato anche il pacchetto mkinitrd, per cui al termine non riusciva a creare la init-ramdisk, e al boot falliva miseramente con qualsiasi filesystem.

Un resoconto dell'installazione (purtroppo in inglese) che finalmente funziona alla grande, è in questa pagina.


La manona che si incontra scendendo verso via Innocenzo XI

home page - send e-mail - continua (next page)